BLOG     |     FORUM
Welcome, Guest
Username: Password: Remember me
Issues related to installation, running, bugs, and features.

TOPIC: Installer Package

Re:Installer Package 10 years 5 months ago #479

The problem with that is the package also creates libpcap.a and libpcap.so that is symlinked to libpcap.so.0.8 etc. Which overwrites the ones I already have there (most things point to just libpcap.so and then that gets symlinked to whatever version is installed so programs that use libpcap don't break). So every time libpcap is updated in the Ubuntu repositories, it would break everything on my system. It's not a sustainable solution for us.
The administrator has disabled public write access.

Re:Installer Package 10 years 5 months ago #480

I agree trying to work around (& fool) apt will rebound on us and introduce a maintenance nightmare.

The best solution is to remove libpcap dependency altogether and use dynamic delay loading to use your special libpcap. This is a bit of work but we already do delay load for Trisul plugins like Geo/Badfellas/ and others.

I will get out a new package tomorrow.


Thanks,
Vivek R
Unleash Networks
Support : www.unleashnetworks.com/forums
The administrator has disabled public write access.

Re:Installer Package 10 years 5 months ago #481

Hello Leif,

The Trisul DEB no longer has dependency on libpcap (or on ncurses).

Please get the new build at :

www.unleashnetworks.com/lib/private/trisul_1.2.716_amd64.deb


1. Uninstall the old trisul, this should clear up apt
2. Install the new one


BTW, I was incorrect yesterday. We had put an explicit dependency on libpcap and libncurses in the package builder script. I removed that.


Thanks,
Vivek R
Unleash Networks
Support : www.unleashnetworks.com/forums
The administrator has disabled public write access.

Re:Installer Package 10 years 5 months ago #482

Installed and working great.

Thanks
The administrator has disabled public write access.
Moderators: vivek [unleash]
Time to create page: 0.044 seconds